How do I know which version of Zenoss I'm running?

There were significant changes in the Zenoss API between versions 3 and 4, this means you need to know which setting to choose in KyK or KyK Lite, so how do you find out?

The simplest solution is to visit your Zenoss login page in a web browser, hope fully you know this as it's also required on the settings pane of KyK.  Once there you should see something like;



The version number in this case is 4.2.0, with 4 being the important number.  In this case the default setting of 'Zenoss v4.x or Above' of 'On' would be correct.  If the first number was less than 4 you should toggle the switch to 'Off'.

Feedback and Knowledge Base